Installation

Build and install the Kynno binaries from source or using Docker. {synopsis}

Pre-requisites

Install additional Linux dependencies

Use the following command to install additional Linux dependencies.

    apt-get update \
    && apt-get install -y --no-install-recommends \
    tzdata \
    ca-certificates \
    build-essential \
    pkg-config \
    cmake

Install Go

::: warning Kynno is built using Go version 1.19+ :::

go version

:::tip If the kynnod: command not found error message is returned, confirm that your GOPATH is correctly configured by running the following command:

export PATH=$PATH:$(go env GOPATH)/bin

:::

Install Binaries

::: tip The latest {{ $themeConfig.project.name }} version is {{ $themeConfig.project.binary }} {{ $themeConfig.project.latest_version }} :::

GitHub

Clone and build {{ $themeConfig.project.name }} using git:

git clone https://github.com/kynnoenterprise/core.git
cd core
make install

Check that the {{ $themeConfig.project.binary }} binaries have been successfully installed:

kynnod version

Releases

You can also download a specific release available on the {{ $themeConfig.project.name }} repository or via command line:

go install github.com/kynnoenterprise/core@latest